IP-FAX(T.38)機器開発向けライブラリ

SUPREE IP-FAX ライブラリ とは ?

SUPREE IP-FAXライブラリは、国際電気通信連合電気通信標準化部門(ITU-T)が定める技術標準T.38に対応したIP-FAX機器開発向けSDKです。
電話接続には、IP電話の標準プロトコルであるSIPを採用しています。
また、NTT東日本/NTT西日本のひかり電話網では、データコネクトによるFAXデータのT.38符号化通信を実現することができ、NGNテストベット検証済みのミドルウェアになります。

T.38によるIP-FAX (FoIP:Fax over IP)は、現状では欧州や北米を中心に成長を見せており、アナログ電話回線からIP網への移行に伴い、さらなる成長が見込まれています。当ライブラリは、すでに複数の複合機(MFP)メーカーに採用されています。

SUPREE IP-FAX ライブラリの特長

IP電話呼制御機能(SIP)

SIP網への登録、発着信、保留・転送などの電話の呼制御に加えて、各種SIPのオプション機能を利用できます。
特にひかり電話環境で使用されるHGW(ホームゲートウェイ) / OGW(オフィスゲートウェイ)に対する簡易設定機能など、NGN網に高い親和性を発揮します。また、IP-FAXのT.38メディア・ネゴシエーションを行う事ができます。

T.38データ通信機能

FAX通信のセッションを確立し、T.38符号化データ通信を実施し、QoSネットワークにおいて送信量制御を行うことができます。

FAXトーン送信および検出機能

T.30勧告に示されるFAX識別信号をVoIP音声ストリームとして送信する事ができます。また、受信FAXトーンの検出を行う事ができ、FAX識別信号に対応するT.38ゲートウェイと接続することもできます。

みなし音声によるIP-FAX機能

VoIP音声ストリームによる「みなし音声IP-FAX」を実装することができます。

  • 別途FAX MODEMライブラリが必要です。

データコネクト対応

ひかり電話のデータコネクト(帯域確保型データ通信サービス)に対応しており、ひかり電話網でのIP-FAXが実現可能です。

提供パッケージ内容

ミドルウェア構成

ライブラリ*1 IP-FAX ライブラリ ソース/バイナリ提供
SIP 呼制御ライブラリ バイナリ提供
VoIP ストリームライブラリ バイナリ提供
サンプルアプリケーション*2 T.38FAXクライアント ソース/バイナリ提供
FAXトーン制御サンプル ソース/バイナリ提供
T.38制御サンプル ソース/バイナリ提供
ドキュメント プログラマーズガイド PDFファイル
APIリファレンス HTMLドキュメント
API呼出シーケンスフロー PDFファイル
サンプルアプリケーションガイド PDFファイル
  1. Linuxリファレンスモジュールとなります。別途、ターゲット機器向けのポーティングが必要となります。
  2. Linuxコマンドライン アプリケーションです。

対応している勧告

主要な標準規格準拠

RFC
RFC1006 ISO Transport Service on top of the TCP Version: 3
RFC2327 Session Description Protocol
RFC2474 Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers
RFC3261 Session Initiation Protocol
RFC3264 An Offer/Answer Model with Session Description Protocol
RFC3266 Support for IPv6 in Session Description Protocol (SDP)
RFC4145 TCP-Based Media Transport in the Session Description
RFC4566 SDP: Session Description Protocol
ITU-T勧告
T.38 Procedures for real-time Group 3 facsimile communication over IP networks
Q.3402 NGN UNI signaling profile (Protocol set 1)

SIP 呼制御仕様

SIP Method INVITE / BYE / ACK / CANCEL / PRACK / REGISTER / INFO / REFER / SUBSCRIBE / NOTIFY / MESSAGE / OPTIONS / UPDATE / PUBLISH *3
SIP server connectivity Registrar / Proxy / B2BUA
Authentication Basic Authentication / Digest Authentication
SDP negotiation T.38 / Audio / Video / Custom
IP protocol UDP/TCP/TLS *4
IPv4/IPv6
Other feature G.711 RTP *5
DiffServ Code Point (DSCP)
  1. IP-FAXでは利用しないメソッドが含まれます。
  2. TLSはSIPにのみ適用できます。また、OpenSSLなどのTLS/SSLキットが別途必要です。
  3. FAX通信ではなく、音声通話の機能になります。

T.38機能対応

IFP packet TYPE field T30_INDICATOR ○
T30_DATA ○
IFP packet format UDPTL ○
TCP/TPKT ○
RTP/AVP ✕
Redundancy/FEC for UDPTL Redundancy frame ○
Parity FEC ✕
Channel model A Pair of unidirectional channels ○
A Single bidirectional channel ○
T.38 ASN.1 notation 1998 ASN.1 syntax, TPKT, IAF support ○
V.34, V.33 support, 2002 syntax extended ○
Call establishment SIP ○
H.323 ✕
H.248.1 for MGC ✕
T.38 SDP Media type ‘image’ ○
Media type ‘application’ ○
All T.38 attributes ○
T.30 Feature CNG/CED tone transmitting on VoIP ○
CNG/CED tone detection on VoIP ○
Other T.30 features ✕

資料請求・お問い合わせ

ご要件やご契約内容によって、提供パッケージ内容やAPIのレイヤが異なります。
お気軽にお問合せください。

SUPREEシリーズ

SIP呼制御
ライブラリ

音声通信制御
ライブラリ

ビデオ通信制御
ライブラリ

IP-FAX
ライブラリ

スマートフォン・タブレット用音声・ビデオ通信総合ライブラリ